The current version of the Mixlr broadcast app supports macOS 10.10 upwards. If you are running 10.10 and upwards and have an issue installing the Mixlr app please contact our support team.


If you are running macOS 10.7, 10.8 or 10.9 we suggest you try installing the previous version of Mixlr (v28) which supports 10.7 upwards. You can download v28 here.

Did this answer your question?